TeamHub - TeamHub Website is down – Incident details

Major system outage

TeamHub Website is down

Identified
Major outage
Started 14 days ago

Affected

TeamHub API

Operational from 6:31 AM to 9:37 PM, Major outage from 9:37 PM to 12:00 AM

TeamHub Website

Operational from 6:31 AM to 6:31 AM, Major outage from 6:31 AM to 12:00 AM

Updates
  • Identified
    Identified
    We are continuing to work on a fix for this incident.
  • Investigating
    Investigating
    TeamHub Website is down at the moment. This incident was automatically created by Instatus monitoring.